summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-06-27 09:19:54 +0200
committerHans de Graaff <graaff@gentoo.org>2021-06-30 08:56:27 +0200
commit98bf2dfbd5b0823a6227bbd069634f1d9c3e40ca (patch)
treeb20788489f6cbd2da48ec68a17e4f74ffcad8182 /dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild
parentdev-ruby/bindex: fix extension install (diff)
downloadgentoo-98bf2dfbd5b0823a6227bbd069634f1d9c3e40ca.tar.gz
gentoo-98bf2dfbd5b0823a6227bbd069634f1d9c3e40ca.tar.bz2
gentoo-98bf2dfbd5b0823a6227bbd069634f1d9c3e40ca.zip
dev-ruby/binding_of_caller: fix extension install; ruby30
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild')
-rw-r--r--dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..51161fe0e1f7
--- /dev/null
+++ b/dev-ruby/binding_of_caller/binding_of_caller-1.0.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="binding_of_caller.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retrieve the binding of a method's caller"
+HOMEPAGE="https://github.com/banister/binding_of_caller"
+SRC_URI="https://github.com/banister/binding_of_caller/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_rdepend ">=dev-ruby/debug_inspector-0.0.1"
+
+all_ruby_prepare() {
+ sed -i -e "s:_relative ': './:" -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+}