summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/bourne
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/bourne')
-rw-r--r--dev-ruby/bourne/Manifest2
-rw-r--r--dev-ruby/bourne/bourne-1.5.0-r1.ebuild32
-rw-r--r--dev-ruby/bourne/bourne-1.6.0.ebuild32
-rw-r--r--dev-ruby/bourne/metadata.xml8
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/bourne/Manifest b/dev-ruby/bourne/Manifest
new file mode 100644
index 000000000000..9d9158b3ec2a
--- /dev/null
+++ b/dev-ruby/bourne/Manifest
@@ -0,0 +1,2 @@
+DIST bourne-1.5.0.gem 15872 SHA256 b96492d4805ca581173bc9e97b7a31f3986d749f94d42abc7bfef20d6ab7a8a1 SHA512 269731d6caea8865ebc12af390b65a4446c42fdfe7ed5308097bb612237a6917e8823ffd916eed67e7a6bcd21417cdfcb4c02325ab44bbaa204635047a7a3f0f WHIRLPOOL 1eef98d4c7c7080791ccaca0b81e8245584761136c9014687045ed81d223e91841a9b7aec448e7aa1ffa3e69b8e8d288b91e93be8b24b73b592066786f0cdba2
+DIST bourne-1.6.0.gem 15872 SHA256 c889471ee13e7aeda661d84a6bb86aa5665b8b69610e949ffde32f419a3a25a5 SHA512 85bdc52b7e86bc86882ac3d815088da1ea882f828613079075a90b3a40cc41ac87bc503b36ee4ee5812374eb1cd83602832b15f2aaf0e01ea54244cc14bf71ac WHIRLPOOL 99c25d0bce9af4e16b1993383066e241ba73efd0ee11b4623318c741ae5323cb09881b68813a1f9a7e48a1958049ba1f97dc37e4c9973f72e732c1085f7af324
diff --git a/dev-ruby/bourne/bourne-1.5.0-r1.ebuild b/dev-ruby/bourne/bourne-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..e6e5709ece6b
--- /dev/null
+++ b/dev-ruby/bourne/bourne-1.5.0-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="MOCHA_OPTIONS=use_test_unit_gem test:units test:acceptance"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends mocha to allow detailed tracking and querying of stub and mock invocations"
+HOMEPAGE="http://github.com/thoughtbot/bourne"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/mocha-0.13.2:0.13"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ sed -i -e '/bundler/d' Rakefile || die
+}
diff --git a/dev-ruby/bourne/bourne-1.6.0.ebuild b/dev-ruby/bourne/bourne-1.6.0.ebuild
new file mode 100644
index 000000000000..4676ec56eaeb
--- /dev/null
+++ b/dev-ruby/bourne/bourne-1.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_TASK_TEST="MOCHA_OPTIONS=use_test_unit_gem test:units test:acceptance"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends mocha to allow detailed tracking and querying of stub and mock invocations"
+HOMEPAGE="http://github.com/thoughtbot/bourne"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/mocha-1.1:1.0"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' "${RUBY_FAKEGEM_GEMSPEC}" || die
+ sed -i -e '/bundler/d' Rakefile || die
+}
diff --git a/dev-ruby/bourne/metadata.xml b/dev-ruby/bourne/metadata.xml
new file mode 100644
index 000000000000..b086ae5fe9ed
--- /dev/null
+++ b/dev-ruby/bourne/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">thoughtbot/bourne</remote-id>
+ </upstream>
+</pkgmetadata>