summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-02-24 09:34:46 +0100
committerHans de Graaff <graaff@gentoo.org>2018-02-24 09:48:15 +0100
commit5643d09e76465307962c9ff2c5445c6e8fa5beb5 (patch)
treeee5ac2ec48bea13def175b37ef5c3f00cf2329a1 /dev-ruby/bson/bson-3.2.6.ebuild
parentdev-ruby/aws-sdk: remove masked version (diff)
downloadgentoo-5643d09e76465307962c9ff2c5445c6e8fa5beb5.tar.gz
gentoo-5643d09e76465307962c9ff2c5445c6e8fa5beb5.tar.bz2
gentoo-5643d09e76465307962c9ff2c5445c6e8fa5beb5.zip
dev-ruby/bson: remove masked version
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/bson/bson-3.2.6.ebuild')
-rw-r--r--dev-ruby/bson/bson-3.2.6.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/bson/bson-3.2.6.ebuild b/dev-ruby/bson/bson-3.2.6.ebuild
deleted file mode 100644
index 771786c4f359..000000000000
--- a/dev-ruby/bson/bson-3.2.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="bson-ruby"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="http://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="bson-ruby-${PV}"
-
-LICENSE="APSL-2"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # Remove project-specific rspec options
- rm .rspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/bson/*$(get_modname) lib/ || die
-}