summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-31 00:10:24 +0100
committerSam James <sam@gentoo.org>2023-03-31 01:50:50 +0100
commit7cc15c912cfa4e1cd3456f38b99f53b8d5b713ed (patch)
tree498e39055c73dcd566072494e24e9c048be7af6c /dev-ruby/bson/bson-4.15.0.ebuild
parentdev-ruby/dbf: enable ruby32 (diff)
downloadgentoo-7cc15c912cfa4e1cd3456f38b99f53b8d5b713ed.tar.gz
gentoo-7cc15c912cfa4e1cd3456f38b99f53b8d5b713ed.tar.bz2
gentoo-7cc15c912cfa4e1cd3456f38b99f53b8d5b713ed.zip
dev-ruby/bson: add 4.15.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/bson/bson-4.15.0.ebuild')
-rw-r--r--dev-ruby/bson/bson-4.15.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/bson/bson-4.15.0.ebuild b/dev-ruby/bson/bson-4.15.0.ebuild
new file mode 100644
index 000000000000..2b68221eb2e7
--- /dev/null
+++ b/dev-ruby/bson/bson-4.15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_EXTENSIONS=(ext/bson/extconf.rb)
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="https://www.mongodb.org/"
+# We prefer rubygems if we can anyway, but note that rubygems has test sources we need,
+# but github *doesn't* (other way around to usual!)
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+ruby_add_rdepend "dev-ruby/json"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+}