summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-18 08:00:41 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-18 08:00:41 +0100
commit283d88a84e5cbd74588e058f835b76e0546f507f (patch)
treeebeb84d0b8c9f0a00efc6a54973aa52ffde29b45 /dev-ruby/bson/bson-4.3.0.ebuild
parentdev-ruby/bson: cleanup (diff)
downloadgentoo-283d88a84e5cbd74588e058f835b76e0546f507f.tar.gz
gentoo-283d88a84e5cbd74588e058f835b76e0546f507f.tar.bz2
gentoo-283d88a84e5cbd74588e058f835b76e0546f507f.zip
dev-ruby/bson: add 4.3.0
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/bson/bson-4.3.0.ebuild')
-rw-r--r--dev-ruby/bson/bson-4.3.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/bson/bson-4.3.0.ebuild b/dev-ruby/bson/bson-4.3.0.ebuild
new file mode 100644
index 000000000000..65464f572e20
--- /dev/null
+++ b/dev-ruby/bson/bson-4.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+GITHUB_USER="mongodb"
+GITHUB_PROJECT="bson-ruby"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
+HOMEPAGE="http://www.mongodb.org/"
+SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="bson-ruby-${PV}"
+
+LICENSE="APSL-2"
+SLOT="4"
+KEYWORDS="~amd64"
+IUSE="test doc"
+
+all_ruby_prepare() {
+ # Remove bundler support
+ sed -i -e '/bundler/I s:^:#:' Rakefile || die
+
+ # Remove project-specific rspec options
+ rm .rspec || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
+ cp ext/bson/*$(get_modname) lib/ || die
+}