summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-08 07:27:51 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-08 07:27:51 +0100
commit1d46c3ce6eeca22a8fa723dee4f1ce6d037c7549 (patch)
tree4db738512c85ec7996d73537ee75bef7617867f0 /dev-ruby/bson/bson-4.5.0.ebuild
parentdev-ruby/bindata: add 2.4.6 (diff)
downloadgentoo-1d46c3ce6eeca22a8fa723dee4f1ce6d037c7549.tar.gz
gentoo-1d46c3ce6eeca22a8fa723dee4f1ce6d037c7549.tar.bz2
gentoo-1d46c3ce6eeca22a8fa723dee4f1ce6d037c7549.zip
dev-ruby/bson: cleanup
Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bson/bson-4.5.0.ebuild')
-rw-r--r--dev-ruby/bson/bson-4.5.0.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/dev-ruby/bson/bson-4.5.0.ebuild b/dev-ruby/bson/bson-4.5.0.ebuild
deleted file mode 100644
index da73b88ea528..000000000000
--- a/dev-ruby/bson/bson-4.5.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="bson-ruby"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="https://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="bson-ruby-${PV}"
-
-LICENSE="APSL-2"
-SLOT="4"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # Remove project-specific rspec options
- rm .rspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/bson/*$(get_modname) lib/ || die
-}