summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-13 06:20:05 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-13 06:20:05 +0200
commit9e4b8ca3a33b8420aaf9143a9f3baee37fbf5e0f (patch)
tree9404683b7a51c894c566cf32d1bf0eaf016b80c8 /dev-ruby/bson/bson-4.8.0.ebuild
parentdev-ruby/asciimath: add 2.0.0 (diff)
downloadgentoo-9e4b8ca3a33b8420aaf9143a9f3baee37fbf5e0f.tar.gz
gentoo-9e4b8ca3a33b8420aaf9143a9f3baee37fbf5e0f.tar.bz2
gentoo-9e4b8ca3a33b8420aaf9143a9f3baee37fbf5e0f.zip
dev-ruby/bson: cleanup
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bson/bson-4.8.0.ebuild')
-rw-r--r--dev-ruby/bson/bson-4.8.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/bson/bson-4.8.0.ebuild b/dev-ruby/bson/bson-4.8.0.ebuild
deleted file mode 100644
index 5e6f5007077a..000000000000
--- a/dev-ruby/bson/bson-4.8.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-GITHUB_USER="mongodb"
-GITHUB_PROJECT="bson-ruby"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A Ruby BSON implementation for MongoDB. (Includes binary C-based extension.)"
-HOMEPAGE="https://www.mongodb.org/"
-SRC_URI="https://github.com/${GITHUB_USER}/${GITHUB_PROJECT}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-RUBY_S="bson-ruby-${PV}"
-
-LICENSE="APSL-2"
-SLOT="4"
-KEYWORDS="~amd64"
-IUSE="test doc"
-
-all_ruby_prepare() {
- # Remove bundler support
- sed -i -e '/bundler/I s:^:#:' Rakefile || die
-
- # Remove project-specific rspec options
- rm .rspec || die
-}
-
-each_ruby_configure() {
- ${RUBY} -C ext/bson extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake -C ext/bson V=1 CFLAGS="${CFLAGS} -fPIC" archflag="${LDFLAGS}"
- cp ext/bson/*$(get_modname) lib/ || die
-}