summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-24 09:37:54 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-24 10:05:48 +0200
commit5fa3063eab2aeab53a0af8bbc1d112aaa50a2415 (patch)
tree86a6a78cc993fe084aae87ca107b848b3255de4e /dev-ruby/bundler/bundler-2.2.29.ebuild
parentdev-lang/ruby: reverse unbundling of did_you_mean (diff)
downloadgentoo-5fa3063eab2aeab53a0af8bbc1d112aaa50a2415.tar.gz
gentoo-5fa3063eab2aeab53a0af8bbc1d112aaa50a2415.tar.bz2
gentoo-5fa3063eab2aeab53a0af8bbc1d112aaa50a2415.zip
dev-ruby/bundler: add 2.2.29
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bundler/bundler-2.2.29.ebuild')
-rw-r--r--dev-ruby/bundler/bundler-2.2.29.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bundler/bundler-2.2.29.ebuild b/dev-ruby/bundler/bundler-2.2.29.ebuild
new file mode 100644
index 000000000000..e03102a40889
--- /dev/null
+++ b/dev-ruby/bundler/bundler-2.2.29.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# The specs require a number of gems to be installed in a temporary
+# directory, but this requires network access. They also don't work
+# when run with a path that contains "-".
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+# No documentation task
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+RUBY_FAKEGEM_BINDIR="exe"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An easy way to vendor gem dependencies"
+HOMEPAGE="https://github.com/carlhuda/bundler"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+doc test"
+
+ruby_add_rdepend virtual/rubygems
+
+RDEPEND+=" dev-vcs/git !<dev-ruby/bundler-1.17.3-r1:0"