summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-09-22 07:27:57 +0200
committerHans de Graaff <graaff@gentoo.org>2018-09-22 07:27:57 +0200
commit326a38e39947bc0720de444a64779e3fea32a66c (patch)
tree5ab6fd70c528fda1e74cb4ce21800d264c02a7b3 /dev-ruby/bunny/bunny-2.12.0.ebuild
parentdev-ruby/faraday: add 0.15.3 (diff)
downloadgentoo-326a38e39947bc0720de444a64779e3fea32a66c.tar.gz
gentoo-326a38e39947bc0720de444a64779e3fea32a66c.tar.bz2
gentoo-326a38e39947bc0720de444a64779e3fea32a66c.zip
dev-ruby/bunny: add 2.12.0
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'dev-ruby/bunny/bunny-2.12.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.12.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.12.0.ebuild b/dev-ruby/bunny/bunny-2.12.0.ebuild
new file mode 100644
index 000000000000..973c02b1ffe4
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.12.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.0:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}