summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-30 07:26:52 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-30 07:43:34 +0200
commit3951f9789eaf461167c236696630c22d73603f26 (patch)
tree32a4092608caa71a640c8b5f60afe85b47580df9 /dev-ruby/bunny/bunny-2.14.3.ebuild
parentdev-ruby/bunny: cleanup (diff)
downloadgentoo-3951f9789eaf461167c236696630c22d73603f26.tar.gz
gentoo-3951f9789eaf461167c236696630c22d73603f26.tar.bz2
gentoo-3951f9789eaf461167c236696630c22d73603f26.zip
dev-ruby/bunny: add 2.14.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bunny/bunny-2.14.3.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.14.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.14.3.ebuild b/dev-ruby/bunny/bunny-2.14.3.ebuild
new file mode 100644
index 000000000000..fca93e2a5458
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.14.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.0:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}