summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-09-01 06:27:40 +0200
committerHans de Graaff <graaff@gentoo.org>2021-09-01 06:27:40 +0200
commitffddb71f5301b52d35d07cf3cf387ece88f04dd8 (patch)
treecf30666c0a6a1b7f706fa1aa283530c5d56e90f6 /dev-ruby/bunny/bunny-2.19.0.ebuild
parentdev-ruby/sorted_set: fix gemspec (diff)
downloadgentoo-ffddb71f5301b52d35d07cf3cf387ece88f04dd8.tar.gz
gentoo-ffddb71f5301b52d35d07cf3cf387ece88f04dd8.tar.bz2
gentoo-ffddb71f5301b52d35d07cf3cf387ece88f04dd8.zip
dev-ruby/bunny: add 2.19.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bunny/bunny-2.19.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.19.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.19.0.ebuild b/dev-ruby/bunny/bunny-2.19.0.ebuild
new file mode 100644
index 000000000000..cb5b6370f0b9
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.19.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="bunny.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/ruby-amqp/bunny"
+SRC_URI="https://github.com/ruby-amqp/bunny/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/amq-protocol-2.3.1:2
+ >=dev-ruby/sorted_set-1.0.2:0"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}