summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-02-27 07:35:24 +0100
committerHans de Graaff <graaff@gentoo.org>2016-02-27 07:35:24 +0100
commit37286c8fd1fe05a3e11a581983d0ff16e7549c1d (patch)
tree35d12ea05e25de6304a536a05d5cb86c76a9a0e7 /dev-ruby/bunny/bunny-2.3.0.ebuild
parentmedia-libs/libsixel: fix build (diff)
downloadgentoo-37286c8fd1fe05a3e11a581983d0ff16e7549c1d.tar.gz
gentoo-37286c8fd1fe05a3e11a581983d0ff16e7549c1d.tar.bz2
gentoo-37286c8fd1fe05a3e11a581983d0ff16e7549c1d.zip
dev-ruby/bunny: add 2.3.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/bunny/bunny-2.3.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.3.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.3.0.ebuild b/dev-ruby/bunny/bunny-2.3.0.ebuild
new file mode 100644
index 000000000000..0c980eb612ed
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.3.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.0.1:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+}