summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-01-24 06:40:56 +0100
committerHans de Graaff <graaff@gentoo.org>2018-01-24 06:40:56 +0100
commitfa8093333a3418b276da5e76a1da49f2a594c8e1 (patch)
treedaf6dc60ab9d2e34c43876dff080a12c369237e4 /dev-ruby/chunky_png/chunky_png-1.3.10.ebuild
parentdev-ruby/chunky_png: cleanup (diff)
downloadgentoo-fa8093333a3418b276da5e76a1da49f2a594c8e1.tar.gz
gentoo-fa8093333a3418b276da5e76a1da49f2a594c8e1.tar.bz2
gentoo-fa8093333a3418b276da5e76a1da49f2a594c8e1.zip
dev-ruby/chunky_png: add 1.3.10
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/chunky_png/chunky_png-1.3.10.ebuild')
-rw-r--r--dev-ruby/chunky_png/chunky_png-1.3.10.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/chunky_png/chunky_png-1.3.10.ebuild b/dev-ruby/chunky_png/chunky_png-1.3.10.ebuild
new file mode 100644
index 000000000000..f94b9a19988a
--- /dev/null
+++ b/dev-ruby/chunky_png/chunky_png-1.3.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_DOCDIR=""
+
+RUBY_FAKEGEM_EXTRADOC="BENCHMARKING.rdoc CHANGELOG.rdoc README.md"
+
+RUBY_FAKEGEM_GEMSPEC="chunky_png.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby library that can read and write PNG images"
+HOMEPAGE="https://wiki.github.com/wvanbergen/chunky_png"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[bB]undler/s:^:#:' {spec,benchmarks}/*.rb || die
+ rm Gemfile* || die
+
+ # Avoid git dependency
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}