summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-05-07 07:54:57 +0200
committerHans de Graaff <graaff@gentoo.org>2022-05-07 08:33:50 +0200
commitfea9335ef8c7ff3b29ba2deded523f514324546a (patch)
tree1508d12ba48e8ce5e55d618b2647bd562236c2f5 /dev-ruby/climate_control/climate_control-1.0.1.ebuild
parentdev-ruby/childprocess: drop 3.0.0, 4.0.0 (diff)
downloadgentoo-fea9335ef8c7ff3b29ba2deded523f514324546a.tar.gz
gentoo-fea9335ef8c7ff3b29ba2deded523f514324546a.tar.bz2
gentoo-fea9335ef8c7ff3b29ba2deded523f514324546a.zip
dev-ruby/climate_control: add 1.0.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/climate_control/climate_control-1.0.1.ebuild')
-rw-r--r--dev-ruby/climate_control/climate_control-1.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/climate_control/climate_control-1.0.1.ebuild b/dev-ruby/climate_control/climate_control-1.0.1.ebuild
new file mode 100644
index 000000000000..afca40f5eb3b
--- /dev/null
+++ b/dev-ruby/climate_control/climate_control-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="NEWS README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Easily manage your environment"
+HOMEPAGE="https://github.com/thoughtbot/climate_control"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and git.
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files/find * -print/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}