summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-05-23 06:04:37 +0200
committerHans de Graaff <graaff@gentoo.org>2018-05-23 06:04:37 +0200
commit9d9ae3c6a8a54c17371889032aeacf4591b923b5 (patch)
tree23954dd31bedfa677eb53898a3cfc67504faa7e1 /dev-ruby/commander/commander-4.4.5.ebuild
parentapp-admin/installer: Add 3_6 to PYTHON_COMPAT (diff)
downloadgentoo-9d9ae3c6a8a54c17371889032aeacf4591b923b5.tar.gz
gentoo-9d9ae3c6a8a54c17371889032aeacf4591b923b5.tar.bz2
gentoo-9d9ae3c6a8a54c17371889032aeacf4591b923b5.zip
dev-ruby/commander: add 4.4.5
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/commander/commander-4.4.5.ebuild')
-rw-r--r--dev-ruby/commander/commander-4.4.5.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/commander/commander-4.4.5.ebuild b/dev-ruby/commander/commander-4.4.5.ebuild
new file mode 100644
index 000000000000..84709c9eacf2
--- /dev/null
+++ b/dev-ruby/commander/commander-4.4.5.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_EXTRADOC="History.rdoc README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The complete solution for Ruby command-line executables"
+HOMEPAGE="https://visionmedia.github.com/commander/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/highline-1.7.2 =dev-ruby/highline-1.7*"
+
+all_ruby_prepare() {
+ sed -i -e "/simplecov/,/end/ s:^:#:" spec/spec_helper.rb || die
+}