summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-04-13 07:23:45 +0200
committerHans de Graaff <graaff@gentoo.org>2021-04-13 07:23:54 +0200
commit62039e7de8b2da3e0cd84c3c6dbab848ddf3f889 (patch)
treec0709c441e93286c602b66b109025f290b03a137 /dev-ruby/connection_pool/connection_pool-2.2.4.ebuild
parentapp-text/evince: Version bump to 40.0 (diff)
downloadgentoo-62039e7de8b2da3e0cd84c3c6dbab848ddf3f889.tar.gz
gentoo-62039e7de8b2da3e0cd84c3c6dbab848ddf3f889.tar.bz2
gentoo-62039e7de8b2da3e0cd84c3c6dbab848ddf3f889.zip
dev-ruby/connection_pool: add 2.2.4
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/connection_pool/connection_pool-2.2.4.ebuild')
-rw-r--r--dev-ruby/connection_pool/connection_pool-2.2.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/connection_pool/connection_pool-2.2.4.ebuild b/dev-ruby/connection_pool/connection_pool-2.2.4.ebuild
new file mode 100644
index 000000000000..ec3d219df836
--- /dev/null
+++ b/dev-ruby/connection_pool/connection_pool-2.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_RECIPE_TEST="rake"
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changes.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Generic connection pooling for Ruby"
+HOMEPAGE="https://github.com/mperham/connection_pool"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' connection_pool.gemspec || die
+ sed -i -e '/\(bundler\|standard\)/ s:^:#:' Rakefile || die
+ sed -i -e "s/gem 'minitest'/gem 'minitest', '~> 5.0'/" test/helper.rb || die
+}