summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-10-24 07:59:59 +0200
committerHans de Graaff <graaff@gentoo.org>2021-10-24 07:59:59 +0200
commit5f612d05abf6351a133cde18b021f558433bdd43 (patch)
tree8ea398bb5422281ee10578fccda8053cca0dd07a /dev-ruby/countdownlatch
parentdev-ruby/concurrent-ruby: cleanup (diff)
downloadgentoo-5f612d05abf6351a133cde18b021f558433bdd43.tar.gz
gentoo-5f612d05abf6351a133cde18b021f558433bdd43.tar.bz2
gentoo-5f612d05abf6351a133cde18b021f558433bdd43.zip
dev-ruby/countdownlatch: EAPI 8; add ruby30
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/countdownlatch')
-rw-r--r--dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild b/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
new file mode 100644
index 000000000000..3b5c7208e942
--- /dev/null
+++ b/dev-ruby/countdownlatch/countdownlatch-1.0.0-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Synchronization aid to allow threads to wait for operations in other threads"
+HOMEPAGE="https://github.com/benlangfeld/countdownlatch"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}