summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-25 07:30:55 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-25 07:30:55 +0100
commit022f5cea5ff6edba63df0a18829720e7363a37cf (patch)
tree99b4a67fe4410f75e03b953b7be289105ad5e921 /dev-ruby/daemons/daemons-1.2.6.ebuild
parentdev-util/cppcheck: remove old (diff)
downloadgentoo-022f5cea5ff6edba63df0a18829720e7363a37cf.tar.gz
gentoo-022f5cea5ff6edba63df0a18829720e7363a37cf.tar.bz2
gentoo-022f5cea5ff6edba63df0a18829720e7363a37cf.zip
dev-ruby/daemons: add 1.2.6
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/daemons/daemons-1.2.6.ebuild')
-rw-r--r--dev-ruby/daemons/daemons-1.2.6.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/daemons/daemons-1.2.6.ebuild b/dev-ruby/daemons/daemons-1.2.6.ebuild
new file mode 100644
index 000000000000..792eabef56a8
--- /dev/null
+++ b/dev-ruby/daemons/daemons-1.2.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="Releases README.md"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Wrap existing ruby scripts to be run as a daemon"
+HOMEPAGE="https://github.com/thuehlinger/daemons"
+SRC_URI="https://github.com/thuehlinger/daemons/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="examples"
+
+all_ruby_prepare() {
+ sed -i -e '/\(pry\|simplecov\)/I s:^:#:' spec/spec_helper.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ use examples || return
+
+ insinto /usr/share/doc/${PF}/
+ doins -r examples
+}