summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/date_validator
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/date_validator')
-rw-r--r--dev-ruby/date_validator/Manifest2
-rw-r--r--dev-ruby/date_validator/date_validator-0.8.0.ebuild49
-rw-r--r--dev-ruby/date_validator/date_validator-0.8.1.ebuild49
-rw-r--r--dev-ruby/date_validator/metadata.xml8
4 files changed, 108 insertions, 0 deletions
diff --git a/dev-ruby/date_validator/Manifest b/dev-ruby/date_validator/Manifest
new file mode 100644
index 000000000000..00d3e3f88ad9
--- /dev/null
+++ b/dev-ruby/date_validator/Manifest
@@ -0,0 +1,2 @@
+DIST date_validator-0.8.0.gem 12288 SHA256 5dc797d1508954955863e8a5d6c00691cd77483c91a094ac32b53d5afb9093e2 SHA512 383faff0dde846c40b554017ff342aee128d8600cd8a32735c8d1eb47578e471664c64f7b833a33d6b7e85d3c40b41e35cb951a1318e1b558b05d17e87c8da98 WHIRLPOOL edeebaefd3e674b3063fc714b811586f026ae9119d34416feb13f8ea4f98392867f1ec6f9b3ac881eba530fe8da529096295cf7c0111fac65d37798e97651956
+DIST date_validator-0.8.1.gem 12288 SHA256 c8d5df377dfb45d6cd8cc0fa0e170d637bdacd423da465ea0f9c658a5745d0cb SHA512 5d894d71853e6f435ba15e2f7f980e982a92ebfae5d7b35acc1b60080b07c44004024e22780afaccaf9cd3b60655e241e633098dfbf2909d5a2316ceb25d9c28 WHIRLPOOL 544d316c05ec222f5319c6c1daaa1c80544efcddbe467a97dd1c8341be326e7acb2694987b36d0042ffc6af6f72130b04ecbf99aa4876c339f67ae5ec2843ee5
diff --git a/dev-ruby/date_validator/date_validator-0.8.0.ebuild b/dev-ruby/date_validator/date_validator-0.8.0.ebuild
new file mode 100644
index 000000000000..126bff1635d0
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.8.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="https://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
+}
diff --git a/dev-ruby/date_validator/date_validator-0.8.1.ebuild b/dev-ruby/date_validator/date_validator-0.8.1.ebuild
new file mode 100644
index 000000000000..126bff1635d0
--- /dev/null
+++ b/dev-ruby/date_validator/date_validator-0.8.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_TASK_TEST="test"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_EXTRADOC="Readme.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+# if ever needed
+#GITHUB_USER="codegram"
+#GITHUB_PROJECT="${PN}"
+#RUBY_S="${GITHUB_USER}-${GITHUB_PROJECT}-*"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Simple, ORM agnostic, Ruby 1.9 compatible date validator for Rails 3"
+HOMEPAGE="https://github.com/codegram/date_validator"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activemodel-3.0:*
+"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest
+ >=dev-ruby/tzinfo-0.3
+ >=dev-ruby/activesupport-3.0
+ )
+ doc? ( dev-ruby/yard )"
+
+all_ruby_prepare() {
+ sed -i \
+ -e '/git ls-files/d' \
+ ${RUBY_FAKEGEM_GEMSPEC} || die
+ sed -i \
+ -e '/[Bb]undler/s/^/#/' Rakefile || die
+ # Fix tests
+ sed -i -e "1irequire 'active_support'" test/test_helper.rb || die
+}
diff --git a/dev-ruby/date_validator/metadata.xml b/dev-ruby/date_validator/metadata.xml
new file mode 100644
index 000000000000..c7e5ea5f4a45
--- /dev/null
+++ b/dev-ruby/date_validator/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">codegram/date_validator</remote-id>
+ </upstream>
+</pkgmetadata>