summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-02-28 07:43:05 +0100
committerHans de Graaff <graaff@gentoo.org>2021-02-28 07:43:05 +0100
commitfbe1335507dfde852c497908c8e37687288a0375 (patch)
tree5d6c54c55701d445897eec72fb7d7c83c0201409 /dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild
parentdev-ruby/binding_of_caller: add 1.0.0 (diff)
downloadgentoo-fbe1335507dfde852c497908c8e37687288a0375.tar.gz
gentoo-fbe1335507dfde852c497908c8e37687288a0375.tar.bz2
gentoo-fbe1335507dfde852c497908c8e37687288a0375.zip
dev-ruby/debug_inspector: add 1.0.0
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild')
-rw-r--r--dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild b/dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild
new file mode 100644
index 000000000000..381ef8b18a2b
--- /dev/null
+++ b/dev-ruby/debug_inspector/debug_inspector-1.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/debug_inspector/extconf.rb)
+
+RUBY_FAKEGEM_GEMSPEC="debug_inspector.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Ruby wrapper for the MRI 2.0 debug_inspector API"
+HOMEPAGE="https://github.com/banister/debug_inspector"
+SRC_URI="https://github.com/banister/debug_inspector/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""