summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-12-20 07:32:53 +0100
committerHans de Graaff <graaff@gentoo.org>2018-12-20 07:32:53 +0100
commitb17543defb890334a5ace15ff6ba65e2e35c0daf (patch)
tree44f3eb79eee1247c8eb6dce8528c6c4bc8b99a35 /dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild
parentapp-crypt/johntheripper-jumbo: fix bug #673414 (diff)
downloadgentoo-b17543defb890334a5ace15ff6ba65e2e35c0daf.tar.gz
gentoo-b17543defb890334a5ace15ff6ba65e2e35c0daf.tar.bz2
gentoo-b17543defb890334a5ace15ff6ba65e2e35c0daf.zip
dev-ruby/did_you_mean: add 1.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild')
-rw-r--r--dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild b/dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild
new file mode 100644
index 000000000000..f50b44e71626
--- /dev/null
+++ b/dev-ruby/did_you_mean/did_you_mean-1.3.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="'did you mean?'experience in Ruby"
+HOMEPAGE="https://github.com/yuki24/did_you_mean"
+
+LICENSE="MIT"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+}