summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-02-12 09:14:56 +0100
committerHans de Graaff <graaff@gentoo.org>2022-02-13 10:06:06 +0100
commitfd1652803e8ef62c271e3690ebf48563fc3cd837 (patch)
tree4b28a7dd29f349f6715fe000c577b70e3b67eff0 /dev-ruby/digest/digest-3.1.0.ebuild
parentdev-ruby/activesupport: cleanup (diff)
downloadgentoo-fd1652803e8ef62c271e3690ebf48563fc3cd837.tar.gz
gentoo-fd1652803e8ef62c271e3690ebf48563fc3cd837.tar.bz2
gentoo-fd1652803e8ef62c271e3690ebf48563fc3cd837.zip
dev-ruby/digest: import 3.1.0
Extracted from dev-lang/ruby, keywords have been migrated. Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/digest/digest-3.1.0.ebuild')
-rw-r--r--dev-ruby/digest/digest-3.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/digest/digest-3.1.0.ebuild b/dev-ruby/digest/digest-3.1.0.ebuild
new file mode 100644
index 000000000000..1f24c462d2a8
--- /dev/null
+++ b/dev-ruby/digest/digest-3.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS="ext/digest/extconf.rb"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="digest.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a framework for message digest libraries"
+HOMEPAGE="https://github.com/ruby/digest"
+SRC_URI="https://github.com/ruby/digest/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e 's/__dir__/"."/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}