summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-12-16 08:41:49 +0100
committerHans de Graaff <graaff@gentoo.org>2022-12-16 10:11:18 +0100
commit1a9f9d707d80c959e20c908b88bba70ee88ce405 (patch)
tree8f94018ecbed416ec781222631dbb6b6f10309a1 /dev-ruby/diva/diva-1.1.1-r1.ebuild
parentdev-ruby/diva: enable ruby30, ruby31 and disable ruby26 (diff)
downloadgentoo-1a9f9d707d80c959e20c908b88bba70ee88ce405.tar.gz
gentoo-1a9f9d707d80c959e20c908b88bba70ee88ce405.tar.bz2
gentoo-1a9f9d707d80c959e20c908b88bba70ee88ce405.zip
dev-ruby/diva: drop unneeded simplecov dep, keyword ~x86
Closes: https://bugs.gentoo.org/738652 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/diva/diva-1.1.1-r1.ebuild')
-rw-r--r--dev-ruby/diva/diva-1.1.1-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ruby/diva/diva-1.1.1-r1.ebuild b/dev-ruby/diva/diva-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..bf880d963c22
--- /dev/null
+++ b/dev-ruby/diva/diva-1.1.1-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+RUBY_FAKEGEM_GEMSPEC="diva.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implementation of expression for handling things"
+HOMEPAGE="https://github.com/toshia/diva https://rubygems.org/gems/diva"
+SRC_URI="https://github.com/toshia/diva/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+ruby_add_rdepend "<dev-ruby/addressable-2.9"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e '/addressable/ s/2.8/2.9/' -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Avoid unneeded dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' -e '1irequire "json"' test/test_helper.rb || die
+}