summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-30 10:06:26 +0200
committerHans de Graaff <graaff@gentoo.org>2022-03-31 07:39:24 +0200
commit7a1049f2e4f5197777e43919f99f21953179c2a6 (patch)
tree82c5ef55416e34a81cf8e8ba1ff0d60a413f3fec /dev-ruby/ed25519/ed25519-1.3.0.ebuild
parentdev-ruby/bcrypt_pbkdf: enable ruby31 and disable ruby25 (diff)
downloadgentoo-7a1049f2e4f5197777e43919f99f21953179c2a6.tar.gz
gentoo-7a1049f2e4f5197777e43919f99f21953179c2a6.tar.bz2
gentoo-7a1049f2e4f5197777e43919f99f21953179c2a6.zip
dev-ruby/ed25519: add 1.3.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ed25519/ed25519-1.3.0.ebuild')
-rw-r--r--dev-ruby/ed25519/ed25519-1.3.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ed25519/ed25519-1.3.0.ebuild b/dev-ruby/ed25519/ed25519-1.3.0.ebuild
new file mode 100644
index 000000000000..259a7fcc67ec
--- /dev/null
+++ b/dev-ruby/ed25519/ed25519-1.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ed25519_ref10/extconf.rb)
+
+RUBY_FAKEGEM_GEMSPEC="ed25519.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library for the Ed25519 public-key signature system"
+HOMEPAGE="https://github.com/crypto-rb/ed25519"
+SRC_URI="https://github.com/crypto-rb/ed25519/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/\(bundler\|coverall\)/I s:^:#:' spec/spec_helper.rb || die
+}