summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/equalizer
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/equalizer')
-rw-r--r--dev-ruby/equalizer/Manifest2
-rw-r--r--dev-ruby/equalizer/equalizer-0.0.11.ebuild28
-rw-r--r--dev-ruby/equalizer/equalizer-0.0.9.ebuild28
-rw-r--r--dev-ruby/equalizer/metadata.xml8
4 files changed, 66 insertions, 0 deletions
diff --git a/dev-ruby/equalizer/Manifest b/dev-ruby/equalizer/Manifest
new file mode 100644
index 000000000000..c887e259fed2
--- /dev/null
+++ b/dev-ruby/equalizer/Manifest
@@ -0,0 +1,2 @@
+DIST equalizer-0.0.11.gem 12800 SHA256 44e5bc46f49883e83d159ee9b1f7320b4ae8283bb6329e5d9716f5e7dde855ce SHA512 01273a8e83124178f5b7d7eed08a4ca6286772c26202e028fa957f3e9d655869c51a7710312a52bb654672c7cbaee5de15fa2eee01c5413f2589cf05e02700a9 WHIRLPOOL b843ca5b5dcfa8fc581f0d462664e2afba656d0186d48344e8025920574d6d609b7c67751e3b00922d78f4cf47d23c39499a1ce0f1022aebe061b831b8af5cb1
+DIST equalizer-0.0.9.gem 12288 SHA256 992b58dc8892afc3c0bde86cd00349b23f01fb702c295c46dd3bfb4f0574dbc4 SHA512 28588e9d42cd2bdaebb9727d35577d0d306578ed85b6a42ec5ca616fd6e858dfc972cca6a2ba3b37cc799d9d6daffc3e9ce73708dc998f7072b83d1cbd8756b2 WHIRLPOOL 8bc9938ed8c99d150d72a28f234b2491cd7c4fc030a9562aaf52e70354eb70537ceb40a050c007f84f1d109e8bbbc86fa1d11ca8ddbf7c932ebcb416c7cc6113
diff --git a/dev-ruby/equalizer/equalizer-0.0.11.ebuild b/dev-ruby/equalizer/equalizer-0.0.11.ebuild
new file mode 100644
index 000000000000..8a4e1ffa0467
--- /dev/null
+++ b/dev-ruby/equalizer/equalizer-0.0.11.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to define equality, equivalence and inspection methods"
+HOMEPAGE="https://github.com/dkubb/equalizer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/devtools/d" spec/spec_helper.rb || die
+
+ # Avoid a failing spec caused by memoizable 0.4.2, and we ignore it
+ # there as well.
+ rm spec/unit/equalizer/included_spec.rb || die
+}
diff --git a/dev-ruby/equalizer/equalizer-0.0.9.ebuild b/dev-ruby/equalizer/equalizer-0.0.9.ebuild
new file mode 100644
index 000000000000..0b2bfa85714b
--- /dev/null
+++ b/dev-ruby/equalizer/equalizer-0.0.9.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Module to define equality, equivalence and inspection methods"
+HOMEPAGE="https://github.com/dkubb/equalizer"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e "/devtools/d" spec/spec_helper.rb || die
+
+ # Avoid a failing spec caused by memoizable 0.4.2, and we ignore it
+ # there as well.
+ rm spec/unit/equalizer/included_spec.rb || die
+}
diff --git a/dev-ruby/equalizer/metadata.xml b/dev-ruby/equalizer/metadata.xml
new file mode 100644
index 000000000000..61b210649a9a
--- /dev/null
+++ b/dev-ruby/equalizer/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">dkubb/equalizer</remote-id>
+ </upstream>
+</pkgmetadata>