summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-06-17 06:39:05 +0200
committerHans de Graaff <graaff@gentoo.org>2019-06-17 06:39:05 +0200
commitf044b5c64644ad1fc143aafa1be97c1924a04b7a (patch)
treeb4bcc67325a8fd1509f56788d9b8d0ecdd0385a3 /dev-ruby/equatable/equatable-0.6.0.ebuild
parentwww-client/chromium: security cleanup (diff)
downloadgentoo-f044b5c64644ad1fc143aafa1be97c1924a04b7a.tar.gz
gentoo-f044b5c64644ad1fc143aafa1be97c1924a04b7a.tar.bz2
gentoo-f044b5c64644ad1fc143aafa1be97c1924a04b7a.zip
dev-ruby/equatable: add 0.6.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/equatable/equatable-0.6.0.ebuild')
-rw-r--r--dev-ruby/equatable/equatable-0.6.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/equatable/equatable-0.6.0.ebuild b/dev-ruby/equatable/equatable-0.6.0.ebuild
new file mode 100644
index 000000000000..b5520ce3dab7
--- /dev/null
+++ b/dev-ruby/equatable/equatable-0.6.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows ruby objects to implement equality comparison and inspection methods"
+HOMEPAGE="https://github.com/piotrmurach/equatable"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ echo "-rspec_helper" > .rspec || die
+}