summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-26 06:53:00 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-26 06:53:00 +0200
commitd8b2724b00d15400c79511aefd6fd3b2cff591ae (patch)
tree0ce46926941955a5e2be636084b2944eac26ad7d /dev-ruby/eventmachine
parentwww-servers/puma: add 3.11.4 (diff)
downloadgentoo-d8b2724b00d15400c79511aefd6fd3b2cff591ae.tar.gz
gentoo-d8b2724b00d15400c79511aefd6fd3b2cff591ae.tar.bz2
gentoo-d8b2724b00d15400c79511aefd6fd3b2cff591ae.zip
dev-ruby/eventmachine: cleanup
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/eventmachine')
-rw-r--r--dev-ruby/eventmachine/Manifest1
-rw-r--r--dev-ruby/eventmachine/eventmachine-1.0.9.1.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-ruby/eventmachine/Manifest b/dev-ruby/eventmachine/Manifest
index 00927b43ebbe..fa1148deea12 100644
--- a/dev-ruby/eventmachine/Manifest
+++ b/dev-ruby/eventmachine/Manifest
@@ -1,2 +1 @@
-DIST eventmachine-1.0.9.1.gem 235008 BLAKE2B d19fea338daeebf1c7c4ca64de7643ff46e455feb500979c1de96d1806d379c337f70189039d700889eb2ef416b35cd45f298656abe6c5ef79ba2da4dba0ffb8 SHA512 5cbc178c604fe9a21850c298f7a5b6f904573f5e1db9e07fee599c5700841c52ec0311a6e50192eff9c1bb45cf30a9dd81d2150fe9d04cabd24cc7c9c32c5df0
DIST eventmachine-1.2.0.1.gem 241152 BLAKE2B f7df9888ba9f3ef731099124ce7cf2b6b396f57dc948feb828f015f2b33426348c87f2443fc6f678e94550167241c2ae154f3679b13b3b7e1bdb6bcdae6cfaab SHA512 a861a2c5172b7cf2720bdb54f52ea96c311c10efdb2f54970054901674e044a72307a5b32210efbbdb78d0472a9b3fb6e898640e1c0b406bdad8b581970e30aa
diff --git a/dev-ruby/eventmachine/eventmachine-1.0.9.1.ebuild b/dev-ruby/eventmachine/eventmachine-1.0.9.1.ebuild
deleted file mode 100644
index 7f0b8880d3c2..000000000000
--- a/dev-ruby/eventmachine/eventmachine-1.0.9.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-USE_RUBY="ruby20 ruby21 ruby22"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="docs/*.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="EventMachine is a fast, simple event-processing library for Ruby programs"
-HOMEPAGE="http://rubyeventmachine.com"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="${DEPEND}
- dev-libs/openssl:0"
-RDEPEND="${RDEPEND}
- dev-libs/openssl:0"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Remove package tasks to avoid dependency on rake-compiler.
- rm rakelib/package.rake || die
-
- # fix test issue - upstream b96b736b39261f7d74f013633cc7cd619afa20c4
- sed -i -e 's/DEBUG/BROADCAST/g' tests/test_set_sock_opt.rb || die
- sed -i -e "/omit_/d" tests/test_*.rb || die
- # Remove the resolver tests since they require network access and
- # the localhost test fails with an IPv6 localhost.
- rm tests/test_resolver.rb || die
- # Needs a tty
- rm tests/test_kb.rb || die
- # Avoid tests that require network access
- sed -i -e '/test_bind_connect/,/^ end/ s:^:#:' \
- tests/test_basic.rb || die
- sed -i -e '/test_\(cookie\|http_client\|version_1_0\)/,/^ end/ s:^:#:' \
- tests/test_httpclient.rb || die
- sed -i -e '/test_\(get\|https_get\)/,/^ end/ s:^:#:' \
- tests/test_httpclient2.rb || die
- sed -i -e '/test_connect_timeout/,/^ end/ s:^:#:' \
- tests/test_unbind_reason.rb || die
- sed -i -e '/test_for_real/,/^ end/ s:^:#:' \
- tests/test_pending_connect_timeout.rb || die
- rm -f tests/test_{get_sock_opt,set_sock_opt,idle_connection}.rb || die
-}
-
-each_ruby_configure() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- ${RUBY} extconf.rb || die "extconf.rb failed for ${extdir}"
- popd
- done
-}
-
-each_ruby_compile() {
- for extdir in ext ext/fastfilereader; do
- pushd $extdir
- # both extensions use C++, so use the CXXFLAGS not the CFLAGS
- emake V=1 CFLAGS="${CXXFLAGS} -fPIC" archflag="${LDFLAGS}" || die "emake failed for ${extdir}"
- popd
- cp $extdir/*.so lib/ || die "Unable to copy extensions for ${extdir}"
- done
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib -S testrb tests/test_*.rb || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- insinto /usr/share/doc/${PF}/
- doins -r examples || die "Failed to install examples"
-}