summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/facter/facter-2.4.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/facter/facter-2.4.3.ebuild')
-rw-r--r--dev-ruby/facter/facter-2.4.3.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/facter/facter-2.4.3.ebuild b/dev-ruby/facter/facter-2.4.3.ebuild
new file mode 100644
index 000000000000..3e8ea45cb905
--- /dev/null
+++ b/dev-ruby/facter/facter-2.4.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="+dmi +pciutils +virt"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ app-emulation/virt-what
+ sys-apps/net-tools
+ sys-apps/lsb-release
+ dmi? ( sys-apps/dmidecode )
+ pciutils? ( sys-apps/pciutils )"
+
+RDEPEND+=" ${CDEPEND}"
+DEPEND+=" test? ( ${CDEPEND} )"
+
+ruby_add_bdepend "test? ( dev-ruby/mocha:1.0 )"
+
+all_ruby_prepare() {
+ # Provide explicit path since /sbin is not in the default PATH on
+ # Gentoo.
+ sed -i -e 's:arp -an:/sbin/arp -an:' lib/facter/util/ec2.rb spec/unit/util/ec2_spec.rb || die
+
+ # Ensure the correct version of mocha is used without using bundler.
+ sed -i -e '1igem "mocha", "~>1.0"' spec/spec_helper.rb || die
+
+ # Avoid because tests try to access outside stuff, e.g. /sys/block
+ sed -i -e '/should load facts on the facter search path only once/,/^ end/ s:^:#:' spec/unit/util/loader_spec.rb || die
+
+ # Allow specs to work with newer rspec 2.x versions.
+ sed -i -e '1irequire "rspec-expectations"' spec/puppetlabs_spec/matchers.rb || die
+
+ # Avoid specs specific to macosx requiring cfpropertylist which is
+ # not available anymore.
+ rm spec/unit/util/macosx_spec.rb || die
+ sed -i -e '/macosx/ s:^:#:' \
+ -e '/on Darwin/,/^ end/ s:^:#:' spec/unit/virtual_spec.rb || die
+ sed -i -e '/Facter::Processors::Darwin/,/^end/ s:^:#:' spec/unit/processors/os_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ # Create the directory for custom facts.
+ keepdir /etc/facter/facts.d
+}