summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2022-06-07 16:07:32 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2022-06-07 16:07:32 -0500
commitccc7daca61be1e57ea90222e731c4fa60aec2039 (patch)
treef76ff74e05ce38d2ef72df4cf8b8bf17c147e1bb /dev-ruby/facter
parentapp-misc/asciinema: Revbump, clean up warnings (diff)
downloadgentoo-ccc7daca61be1e57ea90222e731c4fa60aec2039.tar.gz
gentoo-ccc7daca61be1e57ea90222e731c4fa60aec2039.tar.bz2
gentoo-ccc7daca61be1e57ea90222e731c4fa60aec2039.zip
dev-ruby/facter: 3.14.21 cleanup
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/Manifest1
-rw-r--r--dev-ruby/facter/facter-3.14.21.ebuild99
2 files changed, 0 insertions, 100 deletions
diff --git a/dev-ruby/facter/Manifest b/dev-ruby/facter/Manifest
index bd6ed3fd177e..0c316a579bcc 100644
--- a/dev-ruby/facter/Manifest
+++ b/dev-ruby/facter/Manifest
@@ -1,2 +1 @@
-DIST facter-3.14.21.tar.gz 410594 BLAKE2B 30b502debaec476d7ba03a73ad3a251aeabf3347c2c552204e825dea8d85807d50cd6d06de03be32a5977e5e8cefe4869e2cc453b1ea79b9045c80369df6a0d7 SHA512 69618e54d2c46ae1230fa99ead88413ca8d5be6a01c149fcc00a7485767b9e624283fdf6064679e825a1ecb426be59a86e7ef903cd0ffca58383006ba5e9cf7f
DIST facter-3.14.23.tar.gz 410645 BLAKE2B 7455435d1ab1b1f6e97996aa54be57321bbe0e294652b1aebe0e1ee0e7be45309c1a89fae4079a4350fd6e689c0fe782a7f5d3eee3d766842fba1e8b70a702b7 SHA512 be207d37cf5eac4b6b95cb13e8c2598ccc03af3bcbeedb0d814e5c11c43eb7579427fa1fc1a29eb6db4d6c43b19b2c87c88bd0c85ac3550fa886753267626986
diff --git a/dev-ruby/facter/facter-3.14.21.ebuild b/dev-ruby/facter/facter-3.14.21.ebuild
deleted file mode 100644
index a8b3fb88f65b..000000000000
--- a/dev-ruby/facter/facter-3.14.21.ebuild
+++ /dev/null
@@ -1,99 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-# git-r3 goes after ruby-ng so that it overrides src_unpack properly
-inherit cmake eutils ruby-ng
-
-DESCRIPTION="A cross-platform ruby library for retrieving facts from operating systems"
-HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="test"
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/puppetlabs/facter.git"
- EGIT_BRANCH="master"
-else
- [[ "${PV}" = *_rc* ]] || \
- KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc x86"
- SRC_URI="https://github.com/puppetlabs/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-fi
-
-RESTRICT="!test? ( test )"
-
-ruby_add_bdepend "test? ( dev-ruby/rake dev-ruby/rspec:2 dev-ruby/mocha:0.14 )"
-
-RDEPEND="
- >=dev-cpp/cpp-hocon-0.2.1:=
- >=dev-libs/leatherman-1.0.0:=
- dev-libs/openssl:0=
- sys-apps/util-linux
- app-emulation/virt-what
- net-misc/curl
- dev-libs/boost:=[nls]
- >=dev-cpp/yaml-cpp-0.5.1
- !<app-admin/puppet-4.0.0"
-DEPEND="${RDEPEND}"
-
-# restore ${S} and override all phases exported by ruby-ng.eclass
-S="${WORKDIR}/${P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.14.6-fix-static-libcpp-hocon.patch
- # be explicit about the version of rspec we test with
- "${FILESDIR}"/${PN}-3.14.8-explicit-rspec-2.patch
-)
-
-pkg_setup() {
- ruby-ng_pkg_setup
-}
-
-src_unpack() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- git-r3_src_unpack
- fi
-}
-
-src_prepare() {
- cmake_src_prepare
-}
-
-each_ruby_configure() {
- # hack for correct calculation of relative path from facter.rb to
- # libfacter.so
- my_ruby_sitelibdir=$(ruby_rbconfig_value 'sitelibdir')
-}
-
-src_configure() {
- ruby-ng_src_configure
-
- local mycmakeargs=(
- -DRUBY_LIB_INSTALL=${my_ruby_sitelibdir}
- -DBLKID_LIBRARYDIR="${EPREFIX}/$(get_libdir)"
- )
- cmake_src_configure
-}
-
-src_compile() {
- addpredict /proc/self/oom_score_adj
- cmake_src_compile
-}
-
-src_test() {
- cmake_src_test
-}
-
-each_ruby_install() {
- doruby "${BUILD_DIR}"/lib/facter.rb
-}
-
-src_install() {
- cmake_src_install
- ruby-ng_src_install
-}