summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-12-23 06:49:40 +0100
committerHans de Graaff <graaff@gentoo.org>2020-12-23 06:53:04 +0100
commit29eff4cc20feb7e32681747a25356e176003812e (patch)
tree2756907bb75d3951013f3fd52e6ce2933904521e /dev-ruby/ffi/ffi-1.14.1.ebuild
parentdev-ruby/ffi: cleanup (diff)
downloadgentoo-29eff4cc20feb7e32681747a25356e176003812e.tar.gz
gentoo-29eff4cc20feb7e32681747a25356e176003812e.tar.bz2
gentoo-29eff4cc20feb7e32681747a25356e176003812e.zip
dev-ruby/ffi: add 1.14.1
Closes: https://bugs.gentoo.org/705010 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/ffi/ffi-1.14.1.ebuild')
-rw-r--r--dev-ruby/ffi/ffi-1.14.1.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/dev-ruby/ffi/ffi-1.14.1.ebuild b/dev-ruby/ffi/ffi-1.14.1.ebuild
new file mode 100644
index 000000000000..4a1019bd5d0d
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.14.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ffi.gemspec"
+
+inherit multilib ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="https://wiki.github.com/ffi/ffi"
+
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND+=" virtual/libffi:0="
+DEPEND+=" virtual/libffi"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+all_ruby_prepare() {
+ sed -i -e '/tasks/ s:^:#:' \
+ -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die
+
+ sed -i -e '/require/c\require "./lib/ffi/version"' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix Makefile for tests
+ sed -i -e '/CCACHE :=/ s:^:#:' \
+ -e 's/-O2//' \
+ -e 's/^CFLAGS =/CFLAGS +=/' spec/ffi/fixtures/GNUmakefile || die
+
+ # Remove bundled version of libffi.
+ rm -rf ext/ffi_c/libffi || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ffi_c extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext/ffi_c V=1
+ cp ext/ffi_c/ffi_c$(get_modname) lib/ || die
+
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+each_ruby_test() {
+ CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}