summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-02 20:30:41 +0100
committerSam James <sam@gentoo.org>2021-10-02 20:31:01 +0100
commit4cbfbfe255fc82a05f0a9d3ecdf6e8dce7d9a4ee (patch)
treefe1c69f5522abd448cefa4e1cef670e3d020d9f0 /dev-ruby/ffi/ffi-1.14.2-r1.ebuild
parentapp-misc/mc: Removed unused USE flag description (diff)
downloadgentoo-4cbfbfe255fc82a05f0a9d3ecdf6e8dce7d9a4ee.tar.gz
gentoo-4cbfbfe255fc82a05f0a9d3ecdf6e8dce7d9a4ee.tar.bz2
gentoo-4cbfbfe255fc82a05f0a9d3ecdf6e8dce7d9a4ee.zip
dev-ruby/ffi: fix 32-bit test failure
Thanks-to: Tee KOBAYASHI <xtkoba@gmail.com> Closes: https://bugs.gentoo.org/815130 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ruby/ffi/ffi-1.14.2-r1.ebuild')
-rw-r--r--dev-ruby/ffi/ffi-1.14.2-r1.ebuild68
1 files changed, 68 insertions, 0 deletions
diff --git a/dev-ruby/ffi/ffi-1.14.2-r1.ebuild b/dev-ruby/ffi/ffi-1.14.2-r1.ebuild
new file mode 100644
index 000000000000..450411f52e92
--- /dev/null
+++ b/dev-ruby/ffi/ffi-1.14.2-r1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ffi.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ffi_c/extconf.rb)
+
+inherit multilib ruby-fakegem toolchain-funcs
+
+DESCRIPTION="Ruby extension for programmatically loading dynamic libraries"
+HOMEPAGE="https://wiki.github.com/ffi/ffi"
+
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${PN}-git-${PV}.tgz"
+
+IUSE=""
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND+=" dev-libs/libffi:0="
+DEPEND+=" dev-libs/libffi"
+
+ruby_add_bdepend "dev-ruby/rake"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.14.2-32bit-long-double.patch
+)
+
+all_ruby_prepare() {
+ sed -i -e '/tasks/ s:^:#:' \
+ -e '/Gem::Tasks/,/end/ s:^:#:' Rakefile || die
+
+ sed -i -e '/require/c\require "./lib/ffi/version"' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Fix Makefile for tests
+ sed -i -e '/CCACHE :=/ s:^:#:' \
+ -e 's/-O2//' \
+ -e 's/^CFLAGS =/CFLAGS +=/' spec/ffi/fixtures/GNUmakefile || die
+
+ # Remove bundled version of libffi.
+ rm -rf ext/ffi_c/libffi || die
+}
+
+each_ruby_compile() {
+ each_fakegem_compile
+
+ ${RUBY} -S rake -f gen/Rakefile || die "types.conf generation failed"
+}
+
+each_ruby_test() {
+ CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" ${RUBY} -S rspec spec || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}