summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-07-14 08:15:53 +0200
committerHans de Graaff <graaff@gentoo.org>2019-07-14 08:32:21 +0200
commit04eb0dc9af3bf0032b26787d2d2e92fceb4f259f (patch)
tree86e8c72e8aae8922edb01bc10863a086936f7303 /dev-ruby/google-protobuf
parentdev-ruby/fuubar: add 2.4.1 (diff)
downloadgentoo-04eb0dc9af3bf0032b26787d2d2e92fceb4f259f.tar.gz
gentoo-04eb0dc9af3bf0032b26787d2d2e92fceb4f259f.tar.bz2
gentoo-04eb0dc9af3bf0032b26787d2d2e92fceb4f259f.zip
dev-ruby/google-protobuf: add 3.9.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'dev-ruby/google-protobuf')
-rw-r--r--dev-ruby/google-protobuf/Manifest1
-rw-r--r--dev-ruby/google-protobuf/google-protobuf-3.9.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/google-protobuf/Manifest b/dev-ruby/google-protobuf/Manifest
index 20b307b5951a..86a73052d6c6 100644
--- a/dev-ruby/google-protobuf/Manifest
+++ b/dev-ruby/google-protobuf/Manifest
@@ -1,2 +1,3 @@
DIST google-protobuf-3.6.1-ruby.tar.gz 4485582 BLAKE2B 546c49759df784018459809b9db692c5c94aef5d717183af5cd9edd96b4c658e759f23950cdcd5dddceaaad06ea1de2a2357b9fa8c496ed5d538fc5920174da0 SHA512 1bc175d24b49de1b1e41eaf39598194e583afffb924c86c8d2e569d935af21874be76b2cbd4d9655a1d38bac3d4cd811de88bc2c72d81bad79115e69e5b0d839
DIST google-protobuf-3.8.0-ruby.tar.gz 4934577 BLAKE2B 4b86ab216e8a8b2c99c3620da9417c0562498e9d4dbf4957db186f51c62b0ed73b1322635a076b2d4054e015bdf6c8c50cc7fd0cb78d24a93b29d2a5b48f66fe SHA512 ba27c64e5193cd4a144bf0c9dc0d195fbbe6e580aaca01960362f0f185074588ca40046d3bcea76e1deae7508b722f6c5be484ea957122ae8e98229c7c3a4ad2
+DIST google-protobuf-3.9.0-ruby.tar.gz 4945061 BLAKE2B 11df30465d19b5c057d8c2a18bb944f1abc725056e957fa0ec08803b8d73271daf950852e27273ff4596c88471297608d1ee571a48e615e2c411f79a2d6b5eed SHA512 eebfea7758b924939edaf44d0f51e341f4778dcf943c9e399da57cb5f52e875bda1e37e40841798232dea52082b5d59c20de69a15ddeaf00220c432f05ca0e6e
diff --git a/dev-ruby/google-protobuf/google-protobuf-3.9.0.ebuild b/dev-ruby/google-protobuf/google-protobuf-3.9.0.ebuild
new file mode 100644
index 000000000000..5eefeb1f2412
--- /dev/null
+++ b/dev-ruby/google-protobuf/google-protobuf-3.9.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Protocol Buffers are Google's data interchange format"
+HOMEPAGE="https://developers.google.com/protocol-buffers"
+SRC_URI="https://github.com/protocolbuffers/protobuf/archive/v${PV}.tar.gz -> ${P}-ruby.tar.gz"
+RUBY_S="protobuf-${PV}/ruby"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND+=" test? ( >=dev-libs/protobuf-3.7.0 )"
+
+each_ruby_prepare() {
+ sed -i -e 's:../src/protoc:protoc: ; /^task :build/ s/:compile,//' Rakefile || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/google/protobuf_c extconf.rb
+}
+
+each_ruby_compile() {
+ emake -Cext/google/protobuf_c V=1
+ cp ext/google/protobuf_c/protobuf_c.so lib/google/ || die
+}