summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-12-20 07:32:12 +0100
committerHans de Graaff <graaff@gentoo.org>2017-12-20 07:32:12 +0100
commit0792bbcf6a4623a0fdcd4ae84048713849da1fe4 (patch)
treee774364a977b2cf0f1ee97c15c5fbad17094c533 /dev-ruby/hashie/hashie-3.5.7.ebuild
parentsys-block/sas2ircu: bump to v20, update links and hashes (diff)
downloadgentoo-0792bbcf6a4623a0fdcd4ae84048713849da1fe4.tar.gz
gentoo-0792bbcf6a4623a0fdcd4ae84048713849da1fe4.tar.bz2
gentoo-0792bbcf6a4623a0fdcd4ae84048713849da1fe4.zip
dev-ruby/hashie: add 3.5.7
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/hashie/hashie-3.5.7.ebuild')
-rw-r--r--dev-ruby/hashie/hashie-3.5.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ruby/hashie/hashie-3.5.7.ebuild b/dev-ruby/hashie/hashie-3.5.7.ebuild
new file mode 100644
index 000000000000..4beef2d3980f
--- /dev/null
+++ b/dev-ruby/hashie/hashie-3.5.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hashie is a small collection of tools that make hashes more powerful"
+HOMEPAGE="https://www.mobomo.com/2009/11/hashie-the-hash-toolkit/"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/activesupport )"
+
+all_ruby_prepare() {
+ # Remove bundler and fix one spec that depends on its requires
+ #rm Gemfile || die
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+ sed -e '/pry/ s:^:#:' \
+ -e '1irequire "pathname"; require "tempfile"' -i spec/spec_helper.rb || die
+
+ # Avoid dependency on rspec-pending_for and its dependencies
+ sed -i -e '/pending_for/ s:^:#:' \
+ spec/spec_helper.rb \
+ spec/hashie/mash_spec.rb \
+ spec/hashie/extensions/strict_key_access_spec.rb || die
+
+ # Avoid integration specs to avoid complicated dependencies
+ rm spec/integration/{omniauth*,rails}/integration_spec.rb || die
+}