summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-03-11 08:23:19 +0100
committerHans de Graaff <graaff@gentoo.org>2023-03-11 08:23:19 +0100
commitc9dd533de2e7266a92d4bd989fa4a235d99c94a1 (patch)
tree5d503c1dbca6b6ecbde04abaa4900ccc903cc3ba /dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
parentdev-python/responses: Switch to pypi sdist (diff)
downloadgentoo-c9dd533de2e7266a92d4bd989fa4a235d99c94a1.tar.gz
gentoo-c9dd533de2e7266a92d4bd989fa4a235d99c94a1.tar.bz2
gentoo-c9dd533de2e7266a92d4bd989fa4a235d99c94a1.zip
dev-ruby/hiera-eyaml: drop 3.1.1, 3.2.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild')
-rw-r--r--dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild b/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
deleted file mode 100644
index c20c61b8599b..000000000000
--- a/dev-ruby/hiera-eyaml/hiera-eyaml-3.2.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby26 ruby27"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md PLUGINS.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Encrypted YAML backend for hiera"
-HOMEPAGE="https://github.com/TomPoulton/hiera-eyaml"
-SRC_URI="https://github.com/TomPoulton/hiera-eyaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/highline-1.6.19:*"
-ruby_add_rdepend "dev-ruby/optimist"
-ruby_add_rdepend "!!dev-ruby/hiera-eyaml:0" # both install the /usr/bin/eyaml binary
-
-ruby_add_bdepend "test? ( dev-util/cucumber ~dev-util/aruba-0.6.2 <app-admin/puppet-6 dev-ruby/hiera-eyaml-plaintext )"
-
-all_ruby_prepare() {
- # Fix highline dependency to be compatible with more versions.
- sed -i -e '/highline/ s/~>/>=/' \
- -e '/gem.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
-
- sed -i -e "s:/tmp:${T}:" \
- features/sandbox/puppet/environments/local/modules/test/manifests/run.pp \
- features/sandbox/puppet-hiera-merge/environments/local/modules/test/manifests/run.pp \
- features/sandbox/puppet-envvar/environments/local/modules/test/manifests/run.pp \
- features/puppet.feature
-}
-
-each_ruby_prepare() {
- # Run tests with the correct ruby interpreter
- sed -i -e 's:I run `eyaml:I run `'${RUBY}' '"${S}"'/bin/eyaml:' features/*.feature || die
-
-}
-
-each_ruby_test() {
- ${RUBY} -S cucumber --format progress features || die
-}