summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2015-09-14 07:32:44 +0200
committerHans de Graaff <graaff@gentoo.org>2015-09-14 07:33:19 +0200
commit3193d7b01e841343a7b65e04e7de1d99a174e677 (patch)
tree62357d5dcddc87c543bad0dceb582602b2af3a23 /dev-ruby/hoe/hoe-3.14.1.ebuild
parentapp-admin/syslog-ng: Stable for PPC64 (bug #556546). (diff)
downloadgentoo-3193d7b01e841343a7b65e04e7de1d99a174e677.tar.gz
gentoo-3193d7b01e841343a7b65e04e7de1d99a174e677.tar.bz2
gentoo-3193d7b01e841343a7b65e04e7de1d99a174e677.zip
dev-ruby/hoe: version bump
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-ruby/hoe/hoe-3.14.1.ebuild')
-rw-r--r--dev-ruby/hoe/hoe-3.14.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ruby/hoe/hoe-3.14.1.ebuild b/dev-ruby/hoe/hoe-3.14.1.ebuild
new file mode 100644
index 000000000000..259027f3e34f
--- /dev/null
+++ b/dev-ruby/hoe/hoe-3.14.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="History.rdoc Manifest.txt README.rdoc"
+
+RUBY_FAKEGEM_EXTRAINSTALL="template"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Hoe extends rake to provide full project automation"
+HOMEPAGE="http://www.zenspider.com/projects/hoe.html"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/minitest-5.5:5 )"
+
+ruby_add_rdepend ">=dev-ruby/rake-0.8.7 >=dev-ruby/rdoc-4.0"
+
+all_ruby_prepare() {
+ # Skip isolation
+ sed -i -e '/isolate/ s:^:#:' Rakefile || die
+
+ # Skip test depending on specifics of gem command name
+ sed -i -e '/test_nosudo/,/^ end/ s:^:#:' test/test_hoe.rb || die
+
+ # Gem.bin_wrapper does not work as expected on Gentoo.
+ sed -i -e 's/Gem.bin_wrapper//' lib/hoe/rcov.rb lib/hoe/publish.rb test/test_hoe_publish.rb || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ rdoc --title "seattlerb's hoe-3.5.1 Documentation" -o doc --main README.txt lib History.txt Manifest.txt README.txt || die
+}