summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-10-12 07:17:18 +0200
committerHans de Graaff <graaff@gentoo.org>2017-10-12 07:17:18 +0200
commite31055b85fbc0319ae5c4277e54d68be0f83af46 (patch)
tree726d47766309dd734109510b77a170b19f5660cb /dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
parentdev-ruby/http-form_data: cleanup (diff)
downloadgentoo-e31055b85fbc0319ae5c4277e54d68be0f83af46.tar.gz
gentoo-e31055b85fbc0319ae5c4277e54d68be0f83af46.tar.bz2
gentoo-e31055b85fbc0319ae5c4277e54d68be0f83af46.zip
dev-ruby/http-form_data: add 2.0.0
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ruby/http-form_data/http-form_data-2.0.0.ebuild')
-rw-r--r--dev-ruby/http-form_data/http-form_data-2.0.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild b/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
new file mode 100644
index 000000000000..41f84b29b64a
--- /dev/null
+++ b/dev-ruby/http-form_data/http-form_data-2.0.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Utility-belt to build form data request bodies"
+HOMEPAGE="https://github.com/httprb/form_data.rb"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/,/SimpleCov.start/ s:^:#:' spec/spec_helper.rb || die
+}