summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-09-10 07:39:08 +0200
committerHans de Graaff <graaff@gentoo.org>2021-09-10 07:47:28 +0200
commit4c7b087142a28dfa488ba56a6a41e5669125112e (patch)
treeabc187fb07062a9b1b323a6cca480fc8b4fc91a9 /dev-ruby/httparty
parentdev-libs/dqlite: drop 1.8.0 (diff)
downloadgentoo-4c7b087142a28dfa488ba56a6a41e5669125112e.tar.gz
gentoo-4c7b087142a28dfa488ba56a6a41e5669125112e.tar.bz2
gentoo-4c7b087142a28dfa488ba56a6a41e5669125112e.zip
dev-ruby/httparty: add 0.19.0
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.19.0.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index cedcfd14cf7d..b57bd12401f8 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1 +1,2 @@
DIST httparty-0.18.1.tar.gz 97813 BLAKE2B 3192ad5f1e8c292456710529f4e1595ea5b70ae4ad61695d6d0b036872d40b2afbc0c958ffb25b0c1222ba8004593d20c4d3954c530d6c836e915b87150d954a SHA512 fca9de534199fbf6a058c39c3ebe28587c34df2bffee313a0e05204258fb6b6b6643bd0a28deca9d0b42de21c90c54dab058124349e4774489578fb23e8bacf5
+DIST httparty-0.19.0.tar.gz 101070 BLAKE2B 921858ad7d2daf080f041b08b28b69c29b01bdbf4b399616d46fdd43570a1ec4799c61a9edbd04bcc6c6d60e59fd2a3d6a25a40808f7f294f316d644fb3c4998 SHA512 dcdb66b1940e709c58cd1dbc925a3be44db2d01e0a30992b924aa90554405f1608c3c32e8658b2754e20c822a465202e4ee382e37078e871acbbc37465971011
diff --git a/dev-ruby/httparty/httparty-0.19.0.ebuild b/dev-ruby/httparty/httparty-0.19.0.ebuild
new file mode 100644
index 000000000000..6db437819a69
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.19.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend 'dev-ruby/mime-types:3 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files \?-\?-\?/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '/pry/ s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ #sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+
+ # Avoid test that fails due to unicode normalization differences
+ sed -i -e '/handles international domains/askip "unicode differences"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}