summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-09-19 07:01:55 +0200
committerHans de Graaff <graaff@gentoo.org>2019-09-19 08:03:53 +0200
commite0a2f980408a659e226fcdba2bc0c2319f964a78 (patch)
treee419d6be7fafede0769ceefc34ef4bf5b6bae1a0 /dev-ruby/httparty
parentmedia-fonts/fontawesome: yank 5.10.2 (diff)
downloadgentoo-e0a2f980408a659e226fcdba2bc0c2319f964a78.tar.gz
gentoo-e0a2f980408a659e226fcdba2bc0c2319f964a78.tar.bz2
gentoo-e0a2f980408a659e226fcdba2bc0c2319f964a78.zip
dev-ruby/httparty: add 0.17.1
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/httparty')
-rw-r--r--dev-ruby/httparty/Manifest1
-rw-r--r--dev-ruby/httparty/httparty-0.17.1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/httparty/Manifest b/dev-ruby/httparty/Manifest
index cf04c2c3bca8..619975fa9179 100644
--- a/dev-ruby/httparty/Manifest
+++ b/dev-ruby/httparty/Manifest
@@ -1,2 +1,3 @@
DIST httparty-0.16.4.gem 91136 BLAKE2B 07988ebd768d826753780d1ac0e1cbf26dd592f131af690b8873787dcb00a48553fb5abb8962eb948ed7a877e38faab3103d9be90ee9c9867cc304b7b1a709e0 SHA512 a3465234cdc6118396b385c482a44a0c6aabf37cb81d00186c4f004e63d7c692bf8783c72dad5702d347d2dbf5bd0b54e78fb4852c149851b27d65f886c3525a
DIST httparty-0.17.0.gem 100352 BLAKE2B 49cdb05a5f0f0e6c6e31eae6541333892042227e29b53761636ebf608bca32665ecd0cc538cbc1baca3b0745b89b43a81fff8620e2d96017a60518f46fd9f303 SHA512 9aefaadf364dfe68e8d41cadc4652d0b40ef395d6b0506243a35e771106ca2cc0e9947e1676db39e6f034fd31bde16cc4fb759b78287830681d049ab39178cfb
+DIST httparty-0.17.1.tar.gz 97249 BLAKE2B 044a074c0a11c02d5fd929585b1dd6853871bdbfcf9be0f16b92999ac5e9ad7b0fb60a403a24d4e3ae3901f8fdb119f51e3decfc61e9ddf61419fa50581c1970 SHA512 2e92573e164575c462afceec26234731e8eb4472f127374503ee1361d8399116c78f900f88485629ca7ddb51a6383c963a5b1e21d9d5b0acbcc8544ce3f37465
diff --git a/dev-ruby/httparty/httparty-0.17.1.ebuild b/dev-ruby/httparty/httparty-0.17.1.ebuild
new file mode 100644
index 000000000000..91c3eb58c40d
--- /dev/null
+++ b/dev-ruby/httparty/httparty-0.17.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="httparty.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Makes http fun! Also, makes consuming restful web services dead easy"
+HOMEPAGE="https://jnunemaker.github.com/httparty"
+SRC_URI="https://github.com/jnunemaker/httparty/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend 'dev-ruby/mime-types:3 >=dev-ruby/multi_xml-0.5.2'
+
+ruby_add_bdepend 'test? ( dev-ruby/webmock )'
+
+all_ruby_prepare() {
+ # Remove bundler
+ rm Gemfile || die
+ sed -i -e '/[Bb]undler/ s:^:#:' Rakefile || die
+
+ # Avoid test dependency on cucumber. We can't run the features since
+ # they depend on mongrel which is no longer packaged.
+ sed -i -e '/cucumber/I s:^:#:' Rakefile || die
+
+ # Avoid test dependency on simplecov
+ sed -i -e '/simplecov/I s:^:#:' \
+ -e '1i require "cgi"; require "delegate"' spec/spec_helper.rb || die
+
+ # Avoid test that works standalone but fails in the suite
+ sed -i -e '/calls block given to perform with each redirect/,/^ end/ s:^:#:' spec/httparty/request_spec.rb
+
+ # Avoid test that is not fully compatible with newer multi_xml
+ sed -i -e '/should be able parse response type xml automatically/askip "multi_xml"' spec/httparty_spec.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+}