summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-10-28 08:28:55 +0200
committerHans de Graaff <graaff@gentoo.org>2023-10-28 08:42:29 +0200
commitde75255894bae753df23099ee0e5b6335ba85a0a (patch)
tree89fe34e4a288fd6f23b0e77aaa25438f8580daf5 /dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild
parentdev-ruby/rake: add 13.1.0 (diff)
downloadgentoo-de75255894bae753df23099ee0e5b6335ba85a0a.tar.gz
gentoo-de75255894bae753df23099ee0e5b6335ba85a0a.tar.bz2
gentoo-de75255894bae753df23099ee0e5b6335ba85a0a.zip
dev-ruby/importmap-rails: add 1.2.3
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild')
-rw-r--r--dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild b/dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild
new file mode 100644
index 000000000000..807850e92cad
--- /dev/null
+++ b/dev-ruby/importmap-rails/importmap-rails-1.2.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_EXTRAINSTALL="app"
+# Depends on appraisals, unpackaged dependencies, and unpackaged rails
+# bits.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use ESM with importmap to manage JavaScript in Rails"
+HOMEPAGE="https://github.com/rails/importmap-rails"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/actionpack-6.0.0:*
+ >=dev-ruby/railties-6.0.0:*
+"