summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-21 07:48:01 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-21 07:48:01 +0100
commit23fa50347a00aa870bc126101afcebdc9eb2de42 (patch)
tree1cd0e68e2e82ad33bfc52704654e060ba42fce10 /dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild
parentdev-ruby/instance_storage: cleanup (diff)
downloadgentoo-23fa50347a00aa870bc126101afcebdc9eb2de42.tar.gz
gentoo-23fa50347a00aa870bc126101afcebdc9eb2de42.tar.bz2
gentoo-23fa50347a00aa870bc126101afcebdc9eb2de42.zip
dev-ruby/instantiator: add ruby30
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild')
-rw-r--r--dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild b/dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild
new file mode 100644
index 000000000000..d18a2b82fb39
--- /dev/null
+++ b/dev-ruby/instantiator/instantiator-0.0.7-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Instantiate an arbitrary Ruby class"
+HOMEPAGE="https://github.com/floehopper/introspection"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/blankslate:*"
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/I s:^:#:' Rakefile test/test_helper.rb || die
+}