summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-10-23 09:36:11 +0200
committerHans de Graaff <graaff@gentoo.org>2022-10-23 10:26:31 +0200
commit2c7c25b1613bd416b07e2cba79b60715c312aac3 (patch)
treec6c54f0244f47c28f7f27f06b0d910cbe19ba3ee /dev-ruby/io-event/io-event-1.1.2.ebuild
parentdev-ml/merlin: src_prepare test fixes (diff)
downloadgentoo-2c7c25b1613bd416b07e2cba79b60715c312aac3.tar.gz
gentoo-2c7c25b1613bd416b07e2cba79b60715c312aac3.tar.bz2
gentoo-2c7c25b1613bd416b07e2cba79b60715c312aac3.zip
dev-ruby/io-event: add 1.1.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/io-event/io-event-1.1.2.ebuild')
-rw-r--r--dev-ruby/io-event/io-event-1.1.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/io-event/io-event-1.1.2.ebuild b/dev-ruby/io-event/io-event-1.1.2.ebuild
new file mode 100644
index 000000000000..107271412ff8
--- /dev/null
+++ b/dev-ruby/io-event/io-event-1.1.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="readme.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An event loop"
+HOMEPAGE="https://github.com/socketry/io-event"
+SRC_URI="https://github.com/socketry/io-event/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~sparc"
+IUSE=""
+
+ruby_add_bdepend "test? ( >=dev-ruby/sus-0.6:0 )"
+
+all_ruby_prepare() {
+ sed -i -E 's/require_relative "(.+)"/require File.expand_path("\1")/g' "${RUBY_FAKEGEM_GEMSPEC}" || die
+
+ # Avoid dependency on unpackaged covered package
+ rm -f config/sus.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S sus-parallel || die
+}