summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-01 08:09:07 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-01 08:09:07 +0200
commitd93305702a73adc1796b35de1a7a3a5242eb54d7 (patch)
treedd2a5d8881d415fcefed270d01f9569c1d54e58e /dev-ruby/jmespath/jmespath-1.2.2.ebuild
parentmedia-video/mkvtoolnix: bump to 9.0.1 (diff)
downloadgentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.tar.gz
gentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.tar.bz2
gentoo-d93305702a73adc1796b35de1a7a3a5242eb54d7.zip
dev-ruby/jmespath: add 1.2.2
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.2.2.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.2.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.2.2.ebuild b/dev-ruby/jmespath/jmespath-1.2.2.ebuild
new file mode 100644
index 000000000000..e6d7fd1187ad
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.2.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+}