summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-04-13 06:32:59 +0200
committerHans de Graaff <graaff@gentoo.org>2016-04-13 06:32:59 +0200
commit7a761e922444f797f2f64aa5eb31ef669027ae4c (patch)
treea90b81cc985b6c57245b0b16bd785e8b576f50f6 /dev-ruby/jmespath/jmespath-1.2.4.ebuild
parentdev-ruby/escape_utils: add 1.2.1 (diff)
downloadgentoo-7a761e922444f797f2f64aa5eb31ef669027ae4c.tar.gz
gentoo-7a761e922444f797f2f64aa5eb31ef669027ae4c.tar.bz2
gentoo-7a761e922444f797f2f64aa5eb31ef669027ae4c.zip
dev-ruby/jmespath: add 1.2.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.2.4.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.2.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.2.4.ebuild b/dev-ruby/jmespath/jmespath-1.2.4.ebuild
new file mode 100644
index 000000000000..e6d7fd1187ad
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.2.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+}