summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2016-07-20 07:08:12 +0200
committerHans de Graaff <graaff@gentoo.org>2016-07-20 07:08:12 +0200
commit817df7c63383251888282c53582193a2b82ea506 (patch)
treea14c5093665844f0d9cee345e4ca5ec499df64ea /dev-ruby/jmespath/jmespath-1.3.1.ebuild
parentdev-ruby/libxml: add 2.9.0 (diff)
downloadgentoo-817df7c63383251888282c53582193a2b82ea506.tar.gz
gentoo-817df7c63383251888282c53582193a2b82ea506.tar.bz2
gentoo-817df7c63383251888282c53582193a2b82ea506.zip
dev-ruby/jmespath: add 1.3.1
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.3.1.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.3.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.3.1.ebuild b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
new file mode 100644
index 000000000000..b024b81195df
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}