summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-04-05 07:08:35 +0200
committerHans de Graaff <graaff@gentoo.org>2018-04-05 07:36:15 +0200
commite995313bf591a0c0655967f89e24d18aa415bbc4 (patch)
tree6cd78c4ae119ba152f318effe4367d2cddae0f61 /dev-ruby/jmespath/jmespath-1.4.0.ebuild
parentapp-crypt/{acme,certbot,certbot-apache,certbot-nginx}: remanifest (diff)
downloadgentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.tar.gz
gentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.tar.bz2
gentoo-e995313bf591a0c0655967f89e24d18aa415bbc4.zip
dev-ruby/jmespath: add 1.4.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.4.0.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.4.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.4.0.ebuild b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
new file mode 100644
index 000000000000..60b99b077efc
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.4.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}