summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-02-23 06:49:31 +0100
committerHans de Graaff <graaff@gentoo.org>2022-02-23 06:49:31 +0100
commitda04f2ed243669840e0a3182702c06aa7b93649a (patch)
tree98b55a3a23395e8afb0cebf9ddcc93dce7056f29 /dev-ruby/jmespath/jmespath-1.6.0.ebuild
parentdev-ruby/backports: add 3.23.0 (diff)
downloadgentoo-da04f2ed243669840e0a3182702c06aa7b93649a.tar.gz
gentoo-da04f2ed243669840e0a3182702c06aa7b93649a.tar.bz2
gentoo-da04f2ed243669840e0a3182702c06aa7b93649a.zip
dev-ruby/jmespath: add 1.6.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jmespath/jmespath-1.6.0.ebuild')
-rw-r--r--dev-ruby/jmespath/jmespath-1.6.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.6.0.ebuild b/dev-ruby/jmespath/jmespath-1.6.0.ebuild
new file mode 100644
index 000000000000..b640b015b668
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.6.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_GEMSPEC="jmespath.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}