summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-07-22 10:51:54 +0200
committerHans de Graaff <graaff@gentoo.org>2022-07-22 10:51:54 +0200
commited7924ca0a675fd1b8ef7dbe0a9ead3bfe427ebf (patch)
tree63cab4c4b686542b9f870564cb3080b9ce5ea44d /dev-ruby/jmespath
parentwww-servers/apache: Fix the build with rlibtool (diff)
downloadgentoo-ed7924ca0a675fd1b8ef7dbe0a9ead3bfe427ebf.tar.gz
gentoo-ed7924ca0a675fd1b8ef7dbe0a9ead3bfe427ebf.tar.bz2
gentoo-ed7924ca0a675fd1b8ef7dbe0a9ead3bfe427ebf.zip
dev-ruby/jmespath: fix install to include VERSION file
Closes: https://bugs.gentoo.org/835120 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jmespath')
-rw-r--r--dev-ruby/jmespath/jmespath-1.6.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/jmespath/jmespath-1.6.1-r1.ebuild b/dev-ruby/jmespath/jmespath-1.6.1-r1.ebuild
new file mode 100644
index 000000000000..c3f5e802faf7
--- /dev/null
+++ b/dev-ruby/jmespath/jmespath-1.6.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRAINSTALL="VERSION"
+RUBY_FAKEGEM_GEMSPEC="jmespath.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Implements JMESPath for Ruby"
+HOMEPAGE="https://github.com/jmespath/jmespath.rb"
+SRC_URI="https://github.com/jmespath/jmespath.rb/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="${PN}.rb-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' \
+ spec/{compliance_spec,compliance_without_errors_spec,spec_helper}.rb || die
+ sed -i -e '/bundler/I s:^:#:' spec/spec_helper.rb || die
+}