summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-11-11 07:39:32 +0100
committerHans de Graaff <graaff@gentoo.org>2022-11-11 07:42:02 +0100
commit94e4c965c6c778da6acfd404b458a3d4db967ebb (patch)
treef2e9919a40bd026c751d4e0f5a964bf63762042a /dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild
parentdev-python/wheel: add 0.38.4 (diff)
downloadgentoo-94e4c965c6c778da6acfd404b458a3d4db967ebb.tar.gz
gentoo-94e4c965c6c778da6acfd404b458a3d4db967ebb.tar.bz2
gentoo-94e4c965c6c778da6acfd404b458a3d4db967ebb.zip
dev-ruby/jquery-rails: add 4.5.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild')
-rw-r--r--dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild b/dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild
new file mode 100644
index 000000000000..931ead3aadc7
--- /dev/null
+++ b/dev-ruby/jquery-rails/jquery-rails-4.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md VERSIONS.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="vendor"
+
+RUBY_FAKEGEM_GEMSPEC="jquery-rails.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="jQuery! For Rails! So great"
+HOMEPAGE="https://www.rubyonrails.org"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux"
+
+IUSE=""
+
+ruby_add_rdepend "
+ >=dev-ruby/railties-4.2.0:*
+ >=dev-ruby/thor-0.14:* <dev-ruby/thor-2:*
+ dev-ruby/rails-dom-testing:2"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' jquery-rails.gemspec || die
+}