summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-11-19 07:47:51 +0100
committerHans de Graaff <graaff@gentoo.org>2021-11-19 07:54:26 +0100
commitbdddba44c369349ab622215f5f2f12f911e8ed6a (patch)
tree05506f181c61172600332f9ee21fa92ff1864b9e /dev-ruby/json
parentdev-ruby/hiera-eyaml-plaintext: add ruby30 (diff)
downloadgentoo-bdddba44c369349ab622215f5f2f12f911e8ed6a.tar.gz
gentoo-bdddba44c369349ab622215f5f2f12f911e8ed6a.tar.bz2
gentoo-bdddba44c369349ab622215f5f2f12f911e8ed6a.zip
dev-ruby/json: cleanup
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/json')
-rw-r--r--dev-ruby/json/Manifest1
-rw-r--r--dev-ruby/json/json-2.3.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-ruby/json/Manifest b/dev-ruby/json/Manifest
index d2cb154f1999..b454b5921bff 100644
--- a/dev-ruby/json/Manifest
+++ b/dev-ruby/json/Manifest
@@ -1,3 +1,2 @@
-DIST json-2.3.0.gem 114176 BLAKE2B 329f1305a0cae3d44c74cc7475c7340e86b8447d5e4ffdd5854620669ee4ef5bba0ed7dbc617b0beffb7bfd8b3d79d46ce26feef37685413a4a5a9c230d0ce0c SHA512 9086a64b664f2d774439c0c9f10c2c1cd897684050eb60f8e3ad9256e0b9541deec3bd22fab0bdcf66e3d5bc795720c6923d514b6edb824c9962fc22f162b332
DIST json-2.5.1.tar.gz 131183 BLAKE2B 2ccdf5921ef476b66cb1dbf72cc01763636c82b0eb5d0a5cfc029e14177c7c6766464e7852b11c2424db401f5b931cb64c01d3952929236c9979378a7928ea59 SHA512 4df7ec9b86692376e89c2019c2c1ab3ae9af28fb4742864acc6f985c0551fc10795742cc1124d6435e820617c00d4c5f4aa6c83b21d2fff43ed05cd9d0a89087
DIST json-2.6.1.tar.gz 132705 BLAKE2B 5a8e83b8d11e360402324427de5d2520f39ee1567e2fbf3c92c738546792bb5dec4a9a3c36f3286a3de63161bb5d9f9e7b059c2560f7a3fa50271ce2aa3dc0fc SHA512 e9d0ef77d77ae54a0300b490e3e5c445d0b5aefbce1b160454916bd4f4f8f943131223047e6a7416347cc40d9e7fb1870101c3cbf3a2663a9053f07bdfbd13cf
diff --git a/dev-ruby/json/json-2.3.0.ebuild b/dev-ruby/json/json-2.3.0.ebuild
deleted file mode 100644
index 815eee4af5c5..000000000000
--- a/dev-ruby/json/json-2.3.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="json.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A JSON implementation as a Ruby extension"
-HOMEPAGE="https://github.com/flori/json"
-LICENSE="Ruby"
-
-KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-SLOT="2"
-IUSE=""
-
-RDEPEND="${RDEPEND}"
-DEPEND="${DEPEND}
- dev-util/ragel"
-
-ruby_add_bdepend "dev-ruby/rake
- doc? ( dev-ruby/rdoc )
- test? ( dev-ruby/test-unit:2 )"
-
-all_ruby_prepare() {
- # Avoid building the extension twice!
- # And use rdoc instead of sdoc which we don't have packaged
- # And don't call git to list files. We're using the pregenerated spec anyway.
- sed -i \
- -e '/task :test/ s|:compile,||' \
- -e 's| => :clean||' \
- -e 's|sdoc|rdoc|' \
- -e 's|`git ls-files`|""|' \
- Rakefile || die "rakefile fix failed"
-
- # Remove hardcoded and broken -O setting.
- sed -i -e '/^ \(if\|unless\)/,/^ end/ s:^:#:' \
- -e '/^unless/,/^end/ s:^:#:' ext/json/ext/*/extconf.rb || die
-
- # Avoid setting gem since it will not be available yet when installing
- sed -i -e '/gem/ s:^:#:' tests/test_helper.rb || die
-}
-
-each_ruby_configure() {
- for ext in parser generator ; do
- ${RUBY} -Cext/json/ext/${ext} extconf.rb || die
- done
-}
-
-each_ruby_compile() {
- for ext in parser generator ; do
- emake V=1 -Cext/json/ext/${ext}
- cp ext/json/ext/${ext}/${ext}$(get_modname) ext/json/ext/ || die
- done
-}
-
-each_ruby_test() {
- for t in pure ext ; do
- JSON=${T} ${RUBY} -S rake do_test_${t} || die
- done
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- ruby_fakegem_newins ext/json/ext/generator$(get_modname) lib/json/ext/generator$(get_modname)
- ruby_fakegem_newins ext/json/ext/parser$(get_modname) lib/json/ext/parser$(get_modname)
-}