summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-06-19 09:48:39 +0200
committerHans de Graaff <graaff@gentoo.org>2020-06-19 15:09:38 +0200
commitf0372fd601fbdd6aba8ad228cf1b79637ef8716c (patch)
tree4c948e5de427ddb17c7ddefa3fabbdd01bc19fa0 /dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild
parentdev-ruby/childprocess: add 4.0.0 (diff)
downloadgentoo-f0372fd601fbdd6aba8ad228cf1b79637ef8716c.tar.gz
gentoo-f0372fd601fbdd6aba8ad228cf1b79637ef8716c.tar.bz2
gentoo-f0372fd601fbdd6aba8ad228cf1b79637ef8716c.zip
dev-ruby/kramdown-syntax-coderay: import 1.0.1
New test dependency for www-apps/jekyll Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild')
-rw-r--r--dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild b/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild
new file mode 100644
index 000000000000..32cb7421eb3b
--- /dev/null
+++ b/dev-ruby/kramdown-syntax-coderay/kramdown-syntax-coderay-1.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Uses coderay to highlight code blocks/spans"
+HOMEPAGE="https://github.com/kramdown/syntax-coderay"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE="doc"
+
+ruby_add_rdepend ">=dev-ruby/coderay-1.1:0 dev-ruby/kramdown:2"
+
+each_ruby_test() {
+ ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
+}